Contents

ADVANSYS

Formativ

GroupWise Customization Made Easy!

Distribution Kit

The Advansys Formativ distribution kit is designed to make distributing and registering licensed copies of Formativ throughout your organization as easy as possible. The distribution kit contains:

Sample Novell ZENworks AXT files

Sample Novell GroupWise 6.0 AddOn.CFG files

Sample Setup configuration.ini files

Documentation

To learn about these options, and to start designing your distribution strategy, click here.

Advansys Formativ Distribution Kit Documentation

Information in this document is subject to change without notice. The example companies, products and people are purely fictitious. Without limiting the rights under copyright, no part of this document may be reproduced, stored or introduced into a retrieval system, or transmitted in any form without prior written approval of Advansys corporation.

Advansys may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering the subject matter in this document. Except as expressly provided in any written license agreement from Advansys, the furnishing of this document does not give you any license to these patents, trademarks, copyrights or other intellectual property.

Copyright © 2003 Advansys Pty Limited. All rights reserved.

Formativ is a trademark of Advansys Pty Limited in Australia and other countries.

GroupWise is a trademark of Novell Inc.


Distribution Methods

Advansys Formativ may be installed on a single workstation or on large numbers of workstations within an organization. In order to make the distribution and registration of Formativ as easy as possible, Advansys provides distribution tools and registration utilities.

Formativ consists of a number of files which must be physically copied to each work station and registered. In addition, entries need to be added to the Windows Registry. These two tasks can be achieved by using one of several techniques outlined below:

Registration Utility

The Formativ Registration Utility enables registration of all Formativ products. The utility displays the existing registration status of Formativ components and can be used as a standard application by an individual user or it can be run in silent command line mode for batch product registration. More information about using the Registration Utility can be found here.

Windows Installer

Formativ is supplied as a standard Windows installer application that can be executed on each workstation. (The installer executable is not installed as part of the Distribution Kit. It must be downloaded separately from www.advansyscorp.com or supplied by your reseller). The installer can operate in a number of modes designed to offer a greater deal of installation flexibility. This is probably the best option if you have only a small number (1-5) of personal computers to manage. More information about using the Windows installer can be found here.

Novell ZENworks

Novell ZENworks is Novell's premier desktop management solution. Using ZENworks, it is possible to deploy Formativ quickly to large numbers of workstations within your organization. To make creating Formativ ZENworks Application Objects easy, three ZENworks AXT files are included in the distribution kit. More information about using ZENworks to distribute Formativ can be found here.

GroupWise Distribution Directory

GroupWise 5.5 and 6.0 both provide a facility whereby Formativ Admin or Formativ Runtime can be installed as part of the GroupWise client installation process. More information can be found here.


Registration Utility

Overview

The Registration Utility is a separate program which enables the registration of all installed Formativ products, including trial Flexalock(tm) applets, such as the Business Solutions Pack. When run as a normal Windows application (not in silent command line mode), the Registration Utility displays the registration status of all installed Formativ products, including the number of days a trial applet has left to run.

Registering Formativ Products

The Registration Utility may be used in either standard or command line (see below) mode. Standard mode is when the Registration Utility is run as a normal Windows application without any command line parameters. In standard mode the Registration Utility displays a dialog which allows you to:

view the registration status of all installed Formativ products; and

register Formativ products with a unique registration key provided by a Formativ reseller.

The Registration Utility can be run in standard mode by:

accessing the Windows Programs|Advansys Formativ|Registration Utility menu entry; or

on the Registration tab of the Advansys Formativ About dialog, press the Registration Utility button. The Advansys Formativ About dialog can be found under the GroupWise client's Help menu.

Command Line Parameters

The Registration Utility can be run in silent mode (no user interface displayed) by running the program with the /r- parameter, which takes a registration filename as the parameter data. The file format of the registration file is shown below. This mode allows the batch registration of multiple Formativ products either by placing it in a shared network location or by using a program such as Novell ZenWorks.

To run the Registration Utility in command line mode, run the program with the following parameter:

frmrmg10.exe /r-<registration filename>

where registration filename is the name of the registration file, a text file which should conform to the format shown below. The semi-colon ';' at the beginning of the line identifies it as a comment line and is ignored by the utility.

IMPORTANT: You need to install the appropriate product before you can register it using this utility.

Registration File Format

; Advansys Formativ Registration Utility File

;

; Each line must consist of a product ID, a comma, then the registration code.

; Product IDs are product specific, and will be advised by the applet supplier.

; An example registration might look like the following:

;

; <Product ID>,<registration code>

; Acme Applet Suite,abc123xyz

;

; You may also register Formativ Admin, Formativ Developer, Formativ Runtime and the Business Solutions Pack 1.5

; using this utility. These products use the following product IDs:

;

; Formativ Admin

; Formativ Developer

; Formativ Runtime

; Business Solutions Pack 1.5

; Business Solutions Pack

Note: The 'Business Solutions Pack 1.5' entry referred to above must be used to register the version of the Business Solutions Pack that shipped with Formativ 1.5. The 'Business Solutions Pack' entry must be used to register version 1.6 of the Business Solutions pack and higher.


Windows Installer

Overview

Formativ ships as standard Windows setup programs and most small installations are probably best carried out using this method. The setup program displays a series of dialogs that guide the user through the installation process. It can be executed 'as-is', in which case it will install Formativ using a set of defaults for program location and user configuration. The setup program can also be executed using a series of command line options, all of which are documented below.

NOTE: The Install Local Applets and Data setting has been removed in Formativ 1.6. By default, no applets or data are installed by Formativ Admin, Developer or Runtime setup programs.

Command Line Options

The setup program may be executed with various command line switches. These switches control the installation mode.

/s Silent Mode

The /s switch forces the installation to run without any user interface. This is useful when configuring unattended installations. If you wish to use the /s switch, it must be the first switch to appear on the command line.

/i-<file name> Configuration File Mode

The /i switch is used to specify that a configuration file is to be used during the installation. A configuration file is used to specify a number of settings that will be used during an installation. The configuration file specified must be present in the same location as that of the installation being executed. Full details of the format used by a configuration file are detailed below.

/r-<Registration Code> Register Mode

The /r switch is used to register Formativ once installation of the application is complete. You must provide the registration code exactly as supplied by Advansys, or your reseller, for the registration to be successful.

/ro-<Registration Code> Register Only Mode

The /ro switch is used to register Formativ. It does not install any files, so Formativ must have already been installed on the PC in order to use this parameter. You must provide the registration code exactly as supplied by Advansys, or your reseller, for the registration to be successful.

/u Unregister Mode

The /u switch is used to unregister a previously registered version of Formativ. If this switch is used, all others are ignored. Note that using this switch will not provide another 30 day trial period.

/rs-<Registration Code> Register Business Solutions Pack Mode

The /rs switch is used to register the Business Solutions Pack applets once installation of the application is complete. You must provide the registration code exactly as supplied by Advansys, or your reseller, for the registration to be successful.

/rso-<Registration Code> Register Business Solutions Pack Only Mode

The /rso switch is used to register the Business Solutions Pack applets. It does not install any files, so Formativ and the Business Solutions Pack must have already been installed on the PC in order to use this parameter. You must provide the registration code exactly as supplied by Advansys, or your reseller, for the registration to be successful.

/bsu Unregister Business Solutions Pack Mode

The /bsu switch is used to unregister a previously registered version of the Business Solutions Pack. Note that using this switch will not provide another 30 day trial period.

/nr Do not install the Applet Recorder

The /nr switch forces the installer not to install the Applet Recorder component. The Applet Recorder component is required in order to record actions in GroupWise. Not installing the Applet Recorder means one less TLS index is consumed, which is important when running GroupWise under TLS-scarce Windows 95/NT4. Note: this option is not relevant when using Formativ Runtime, which does not include the Applet Recorder.

/nb Do not install the Command Blocker

This option is no longer supported, starting from Formativ 1.5.6.0 (October 30, 2002). The /nb switch forces the installer not to install the Command Blocker component. The Command Blocker component is required in order to execute applets that are able to block/disable GroupWise commands. Not installing the Command Blocker means one less TLS index is consumed, which is important when running GroupWise under TLS-scarce Windows 95/NT4.

/nd Disable the GroupWise 'Tip of the Day' C3PO

The /nd switch disables the GroupWise 'Tip of the Day' C3PO if enabled. The GroupWise 'Tip of the Day' C3PO consumes resources that are scarce under Windows 95/NT4, even if configured not to display tips in GroupWise. Disabling the 'Tip of the Day' C3PO means three less TLS indexes are consumed, which is important when running GroupWise under TLS-scarce Windows 95/NT4.

Configuration File

If the setup program is executed with the /i command switch, it first checks to see if a plain text file with the name specified after the switch exists in the same location from which the installation is executing. (Three sample configuration files are installed with the distribution kit: formativ_full.ini, formativ_pgm.ini and config_example.ini). If such a file exists, it reads a number of settings from this file and uses those settings in place of the defaults used by the setup program. An example of a complete installation INI file is shown here. No single value entry is essential, and you may elect to include only value lines for those settings you wish to override.

;--------------------------------------------------------------------------------

; Advansys Formativ Example Installation Configuration File

;

; This file documents the possible settings that can be used to control the

; installation of Formativ 1.5. All values are optional. Not all options are

; applicable to all versions of Formativ. See the Distribution Kit Guide for details.

;--------------------------------------------------------------------------------

;--------------------------------------------------------------------------------

; Specifies default paths

;--------------------------------------------------------------------------------

[Paths]

Local Applets=C:\data\local

User Data=C:\data\user

Library Backup=C:\data\backup

System Path=C:\Program Files\Advansys\Formativ\System

User Cache Path=C:\Program Files\Advansys\Formativ\Mirror

Local Images Path=C:\Program Files\Advansys\Formativ\applet_img

Local Help Path=C:\Program Files\Advansys\Formativ\applet_hlp

Local Config Path=C:\Program Files\Advansys\Formativ\applet_cfg

;--------------------------------------------------------------------------------

; Specifies default config

;--------------------------------------------------------------------------------

[Configuration]

Maintain Existing Path Settings=1

Portal Folder Enabled=1

Display No Solutions Warning=1

Quick Config=1

Registration Utility=1

Help Center=1

Redirect Associations=1

Create Settings for All Users=0

;--------------------------------------------------------------------------------

; Specifies the network protocol to use when accessing applets stored in the

; Directory.

;

; Usage:

; 0 - None (Use local applets only)

; 1 - NDAP if the NetWare client is installed, otherwise use LDAP

; 2 - Use specific protocol as indicated by the Override setting (see below)

;

; Override:

; 0 - NDAP (defaults to local access if the NetWare client is not installed)

; 1 - LDAP

;

;--------------------------------------------------------------------------------

[Protocol]

Usage=1

Override=1

;--------------------------------------------------------------------------------

; Specifies default LDAP settings

;--------------------------------------------------------------------------------

[LDAP]

Port=389

SSL Port=636

Use SSL=0

Server=

Username=

Certificate=

Certificate Source=

Server Requires Logon=1

Save Password=1

Allow Anon Login=0

Automatic Login=1

Default Password=

Ignore Bind Failure=0

Use Default Username=0

Use Default Password=0

Save Username and Password Feature Enabled=1

The use of each value is shown below:

Local Applets=<path>

This setting controls where Formativ will store personal applets for this user. This could be a directory on a local PC or a network directory. If this setting is not specified, Formativ will use a directory called \Local under the Formativ program directory.

User Data=<path>

This setting controls where user data will be located. The Formativ applet language contains a function which returns this location, and is used by many applets to access data files. If this setting is not specified, Formativ will use a directory called \Data under the Formativ program directory.

Library Backup=<path>

This setting controls the location to which an administrator will backup shared applets. If this setting is not specified, Formativ will use a directory called \Backup under the Formativ program directory. See the Administrators Guide for more details about Formativ Administrators.

System Path=<path>

This setting controls the location in which licence and manifest files will be stored. If this setting is not specified, Formativ will use a directory called \System under the Formativ program directory.

User Cache Path=<path>

This setting controls where the user cache (mirror) data will be located. If this setting is not specified, Formativ will use a directory called \Mirror under the Formativ program directory.

Local Images Path=<path>

This setting controls where the local applet images will be located. If this setting is not specified, Formativ will use a directory called \applet_img under the Formativ program directory.

Local Help Path=<path>

This setting controls where the local applet help files will be located. If this setting is not specified, Formativ will use a directory called \applet_hlp under the Formativ program directory.

Local Config Path=<path>

This setting controls where the local applet configuration files will be located. If this setting is not specified, Formativ will use a directory called \applet_cfg under the Formativ program directory.

NDS Administered=[1,0]

The use of this setting has been deprecated.

Maintain Existing Path Settings=[1,0]

This setting specifies whether any existing path settings should be used for this installation. A value of 1 equals true, 0 equals false.

Portal Folder Enabled=[1,0]

This setting specifies whether the Formativ Portal Folder is to be enabled in the GroupWise client. A value of 1 equals true, 0 equals false.

Display No Solutions Warning=[1,0]

This setting specifies whether the no solutions warning dialog is displayed when GroupWise starts if no solutions are installed. A value of 1 equals true, 0 equals false.

Quick Config=[1,0]

This setting specifies whether the Quick Config application is installed. (The Quick Config application allows users to delete and enable/disable local applets). A value of 1 equals true, 0 equals false.

Registration Utility=[1,0]

This setting specifies whether the Registration utility is installed. (The Registration Utility allows users to register both Formativ and the solution packs). A value of 1 equals true, 0 equals false.

Help Center=[1,0]

This setting specifies whether the Help Center is installed. (The Help Center allows users to to receive almost real time online updates from the Advansys web site). A value of 1 equals true, 0 equals false.

Redirect Associations=[1,0]

This setting specifies whether the association between the Windows Script Host and VBS/VBE extensions is disabled each time Formativ is started. A value of 1 equals true, 0 equals false. The default is true (1).

Create Settings for All Users=[1,0]

This setting specified whether the settings used will be applied to all users of Formativ on the current machine, or the current user only. The default is 0 (settings apply to the current user only).

Usage=[0,1,2]

This setting specifies the network protocol to use when accessing applets stored in eDirectory. A value of 0 indicates that no protocol should be used and that Formativ should just run applets from the local applet folder. A value of 1 is an auto-selection option, where Formativ will use the NetWare client if installed (NDAP protocol) or otherwise it will attempt to use LDAP protocol to access eDirectory. A value of 2 specifies that Formativ should use the Override setting below.

Override=[1,0]

This setting forces Formativ to use a specific protocol to access eDirectory. A value of 0 forces Formativ to use the NetWare client's NDAP protocol, while a value of 1 forces Formativ to use LDAP.

Port=<port number>

This setting defines the port number to use when LDAP protocol is used. The default value is 389.

SSL Port=<port number>

This setting defines the port number to use when LDAP protocol is used in SSL mode. The default value is 636.

Use SSL=[1,0]

This setting defines whether a secure connection, SSL, should be used when making a LDAP connection to the eDirectory server. A value of 1 indicates the use of SSL and 0 is a non-secure connection.

Server=<server address>

This setting is the IP address of the LDAP server.

Username=<user name>

If required, this setting represents the User ID required for logging into the LDAP server. The user name parameter must conform to the LDAP naming conventions, for example, cn=<username>, ou=<organizational unit>,o=<organization>.

Certificate=<Full Certificate Path>

This setting is the full path and name of the LDAP certificate to be used when connecting to the server.

Certificate Source=<Full Certificate Source Path>

This setting is the full path and name of the LDAP certificate you wish to be copied from during an installation. If supplied, this certificate will be copied to the name and location given in the Certificate setting (see above).

Server Requires Logon=[1,0]

This setting identifies whether a specific LDAP login is required when Formativ is initialized upon GroupWise startup. A value of 1 indicates a login is required by the LDAP server.

Save Password=[1,0]

This setting specifies whether the LDAP password should be saved in the current user's GroupWise account. Enabling this feature means users do not have to supply a password each time Formativ is loaded. If selected, the password is saved in a highly encrypted form.

Allow Anon Login=[1,0]

This setting specifies whether users are able to connect to the given LDAP server as an anonymous user. If set to false, users must supply a valid password when connecting.

Automatic Login=[1,0]

This setting indicates whether Formativ should attempt to authenticate to the LDAP server using the settings that exist in the registry without displaying the LDAP login dialog. A value of 1 indicates yes, 0 indicates no. The LDAP login dialog will appear if insufficient information exists in the registry.

Default Password=<Password>

This setting is used to specify a default LDAP password for the user. This value will be used to attempt to authenticate to the given LDAP server if not password can be obtained from the users GroupWise account. This setting is typically used when you wish to pre-define a username and password for the user, where the username is a generic user object with minimal rights in the directory, other than rights to the appropriate configuration and applet objects.

Ignore Bind Failure=[1,0]

This setting is used to indicate if Formativ should ignore any LDAP bind failure and continue the startup process without notifying the user a problem occurred. The default is false (0). Note that setting this value will remove all indications that the bind failed, and should only be set by advanced users.

Use Default Username=[1,0]

This setting is used to indicate if Formativ is to attempt to authenticate to the given LDAP server using the username value stored in the registry. Any value stored in the users GroupWise account is ignored. The default value is false (0).

Use Default Password=[1,0]

This setting is used to indicate if Formativ is to attempt to authenticate to the given LDAP server using the default password value stored in the registry. Any value stored in the users GroupWise account is ignored. The default value is false (0).

Save Username and Password Feature Enabled=[1,0]

This setting is used to enable or disable the save username and password LDAP feature The default value is true (1).


ZENworks

Introduction

Novell ZENworks is Novell's premier desktop management solution. ZENworks for Desktops makes it very easy to roll out and register Formativ Admin and Formativ Runtime automatically for large numbers of users from a central location. ZENworks also makes it very easy to update Formativ whenever new software becomes available.

Note: ZENworks is a large, powerful application with many options, configurations and uses. The following assumes a strong working knowledge of ZENworks for Desktops, including the creation, editing and use of ZENworks Application Objects. Please refer to your ZENworks documentation for full details.

Using the supplied AXT Files

Advansys has provided three sample ZENworks AXT files (formativ.axt, formativruntime.axt and formativ_uninstall.axt) which you can edit and import into eDirectory/NDS to create ZENworks Application Objects that carry out installation, registration and uninstallation. Please note that, while every care has been taken in the preparation of these files, the requirements of your site may differ from those used to create these files. You will almost certainly need to edit the resulting ZENworks Application Objects to suite your specific requirements, particularly in regards to source file locations.

formativ.axt

FORMATIV.AXT is used to build a ZENworks Application Object that installs and registers Formativ on a workstation. The AXT file executes the standard Formativ installation program, and optionally passes a number of command line parameters to the installer in order to customize the installation. Like all AXT files, you will need to edit its contents to ensure that it works appropriately in your environment. For full details on the usage of the command line parameters, please see the comments in the AXT file or the installer documentation.

formativruntime.axt

FORMATIVRUNTIME.AXT is used to build a ZENworks Application Object that installs and registers Formativ Runtime on a workstation. The AXT file executes the standard Formativ Runtime installation program, and optionally passes a number of command line parameters to the installer in order to customize the installation. Like all AXT files, you will need to edit its contents to ensure that it works appropriately in your environment. For full details on the usage of the command line parameters, please see the comments in the AXT file or the installer documentation.

formativ_uninstall.axt

FORMATIV_UNINSTALL.AXT is used to build a ZENworks Application Object that uninstalls Formativ Admin or Formativ Runtime from a workstation. The AXT file executes the standard Formativ Admin and Formativ Runtime uninstallation program. Like all AXT files, you will need to edit its contents to ensure that it works appropriately in your environment.


GroupWise Add On Directory

Introduction

GroupWise 5.5 and 6.x users can take advantage of the GroupWise Add On Directory facility to install Formativ Admin or Formativ Runtime as part of a standard GroupWise client installation. To use this facility, you must create an ADDON.CFG file. The ADDON.CFG file is an ASCII text file that supports extended ASCII characters. The GroupWise client setup program uses the ADDON.CFG file to install additional components on users' workstations such as Formativ. The ADDON.CFG is specific to each program being installed. The required program files and the associated ADDON.CFG file must be copied to a subdirectory under software_distribution_directory\CLIENT\WIN32\ADDONS.

During client installation, the GroupWise setup program will search the subdirectories under the \ADDONS directory for any ADDON.CFG files. The setup program will then execute the installation program for that component using the settings specified in the ADDON.CFG. If an entry is missing in the ADDON.CFG file, the installation program will prompt the user for the required information.

Full details regarding the use of the Add On directory can be found in Novell's GroupWise documentation. (http://www.novell.com/documentation/lg/gw6/index.html?gw6_admin/data/a2iiiqh.html).

Sample AddOn.CFG file

Two sample AddOn.CFG files are included in the distribution kit and the file content for Formativ Runtime is shown below. You may need to edit this file to suit your own requirements. Please see the Novell GroupWise setup documentation for full details on the use of the AddOn.CFG file:

; This section is used by the GroupWise client setup program.

;

[GroupWiseAddon]

; Install - Install executable, you should not change this

;

Install=formativruntime.exe

; Parameters - Parameters which can be passed to install (see Formativ Distribution documentation)

;

;/s Silent mode (must be first parameter)

;/r-<Code> Register application during installation

;/ro-<Code> Regisgter application only without software installation

;/u Unregister application

;/i-<config file> Use the given config file to override default settings

;

;Command Line Notes:

;

;The /u (unregister) switch takes precedence over all other switches. If this switch

;is present all others are ignored and the product is simply unregistered. No other files are installed.

Parameters=/s

; Silent - You should not change this, it will

; be automatically appended to the parameters when a silent client install

; is performed

;

Silent=

; Size - Installed size of the addon in kilobytes

;

Size=6770

; Workstation - Yes=Allow for a workstation install

; No=Do not allow for a workstation install

;

; The shipping default for Workstation is: Workstation=Yes

;

Workstation=Yes

; Default - Yes = Default checked in list of components

; No = Default unchecked

;

; The shipping default for Default is: Default=Yes

;

Default=Yes

; Hide - Control whether addon shows in list of components

; Yes=Hide option, uses Default to install or not

; No=User can choose to install or not

;

; The shipping default for Hide is: Hide=No

;

Hide=No

; If this addon appears in the client setup for user selection, this is the

; name that will appear

;

[Name]

US=Advansys Formativ Runtime

; If this addon appears in the client setup for user selection, this is the

; description that will appear

;

[Description]

US=Advansys Formativ Runtime provides the ability to run Encoded and eDirectory based Formativ applets


.topic 5
TLS Indexes are Windows resources used by all applications.  Each application has a set number of TLS indexes available.  The actual number of indexes available to an application is dictated by the version of Windows used:   Windows Version TLS Indexes Available Windows 95 64 Windows NT4.0 64 Windows 98 80 Windows ME 80 Windows 2000 1088 Windows XP 1088   GroupWise consumes a number of the available indexes, leaving the remainder for use by other modules that extend GroupWise, including Formativ.  Different GroupWise features consume additional TLS indexes, including the Spell Checker, QuickView and HTML views.  This is not usually an issue with Windows 98/XP, and never a problem with Windows 2000/XP.  However, Windows 95 and NT4.0, with only 64 indexes available per process, can run out of indexes under certain circumstances.  For example, using the QuickView, HTML views and spell checker all consume TLS indexes (some of which are not returned to the pool when the feature is turned off).  If not enough indexes are available when required, GroupWise and/or Formativ can behave erratically.  This is normally observed as problems using the GroupWise spell checker.


TLS

TLS Indexes are Windows resources used by all applications. Each application has a set number of TLS indexes available. The actual number of indexes available to an application is dictated by the version of Windows used:

Windows Version | TLS Indexes Available
Windows 95 | 64
Windows NT4.0 | 64
Windows 98 | 80
Windows ME | 80
Windows 2000 | 1088
Windows XP | 1088

GroupWise consumes a number of the available indexes, leaving the remainder for use by other modules that extend GroupWise, including Formativ. Different GroupWise features consume additional TLS indexes, including the Spell Checker, QuickView and HTML views. This is not usually an issue with Windows 98/XP, and never a problem with Windows 2000/XP. However, Windows 95 and NT4.0, with only 64 indexes available per process, can run out of indexes under certain circumstances. For example, using the QuickView, HTML views and spell checker all consume TLS indexes (some of which are not returned to the pool when the feature is turned off). If not enough indexes are available when required, GroupWise and/or Formativ can behave erratically. This is normally observed as problems using the GroupWise spell checker.