/ Forums / Advansys Formativ / eDirectory/NDS Management / Admin Issues with Edirectory

  • Creator
    Topic
  • #3506
    travisjp2g
    Participant

    Hi,

    I have been searching through the support forum for help with this issues and nothing si working for me. I cannot get Admin Mode working on my grouwpise account to apply or edit applets. I have never had it working since I newly insatlled it. I have deleted and recreated all the NDS info many times but still cannot see global applets within the manage side.

    Please help

  • Author
    Replies
  • #5289
    Support 2
    Moderator

    As we currently have no known problems with the eDirectory distribution, it is probable the problem lies in a specific environmental or configuration issue.

    When configuring your eDirectory installation, did you follow the steps in the eDirectory Quick Start section of the Studio Users Guide?

    In order to identify the problem, we will need to gather information about your installation. Can you please send to support@advansyscorp.com, the following information.

    1) The Formativ objects you have created in eDirectory, where they are located and what rights have been assigned to them.

    2) The Formativ Studio configuration information by selecting the GroupWise client’s Help menu, select About Formativ, select the Configuration tab and use the Copy to Clipboard button, then paste the config info into the email to Support.

    After receiving the information above, we should hopefully be able to start tracing the source of the problem.

    Regards,

    Advansys Support

    #5291
    akonecny
    Participant

    What are the indications that we have actually successfully entered Admin mode?
    I’m running as Admin equivilant, to be sure have also granted all rights to .Formativ.CoName container. In that container I have three objects, Gobal Config(advansysFvConfig), Global Applets(no Object Class), & FormativAdministrator(Org role). Under FormativAdministrator I am listed under ‘Security Equal to Me”, I can’t find any other place to add me to.
    Under Global Applets, I’m listed as a ‘Library Administrators’

    But I still can’t publish to eDir from Formativ Studio.
    The fact that my Global Applets contain has no object class (as seen from the other tab in C1) is suspisious, but I’m not sure if that is how it should be or not, and if not how to fix (? just add the class advansysFvLibType ?)

    I have tried from both my usual account and Admin itself, and have tried on two different notebooks, all with the same results.

    I do not have a Corporate Applets under my FormativCentral
    I am using ConsoleOne 1.36e with Formativ Admin snap-in 1.6

    #5290
    Support 2
    Moderator

    It certainly appears the problem is related to the fact you cannot see an object class for the Global Applets object, which I assume is a Formativ Applet Library or the class called advansysFvScriptLib.

    Unfortunately, we do not have other reports of a similar nature which may offer an explanation.

    Perhaps the schema did not extend successfully or there is a problem with the Formativ snapin? Were there any errors when you ran the schema extension Wizard?

    I have updated from 1.3.6 to 1.3.6e and all seems to work fine here with respect to the Formativ snapin.

    I presume you have been following the information in the Formativ Studio guide with respect to eDirectory integration?

    When running in Formativ Administration mode, when you start Formativ Studio, you should see in the status bar (left hand side bottom) of the dialog, the text:

    Administrator Mode (your email address)

    In addition, you can see the Formativ Configration information in the Formativ About dialog. This may provide some clues, although I suspect you need to identify why the object class for the Formativ Applet Library is not visible.

    If you cannot determine the cause and rectify the missing class issue, we will need to consider the next step in troubleshooting.

    Regards,

    Advansys Support

    #5292
    akonecny
    Participant

    I figured it out, it was a bit of a Dooh! moment I think.
    At this client I tend to use two different eDir accounts, and I had missed one little thing on the more godly account(admin) I was mostly logged into eDir as, and I was logged into GW as akonecny (mearly a ‘super user’ account at eDir level)
    What I missed was doing the Associate for admin in the Config object

    as for the Applets object, I do see the object class with DSBrowse, so I might just have an issue with my ConsoleOne not seeing it in the ‘Other’ tab where it tends to show in other objects.

    fun thing is that I figured this out on only 3 hours of sleep, patching GWIA and WebAccess shouldn’t cause them to ABEND, but that was last nights late entertainment.

    Andy Konecny
    Ainsworth Inc in Toronto Canada
    “the latest is not necessarily the greatest”

    #5288
    Support 2
    Moderator

    Hi Andy,

    Thanks for the update and good news.

    And I hope you get some well-earned rest. Wink

    Regards,

    Advansys Support

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.