/ Forums / Advansys Archive To Go, Advansys PST Creator / Archive To Go / Error when selecting “Enterprise Access” & GW System

  • Creator
    Topic
  • #4881
    tbengert
    Participant

    When creating an archive I select “Enterprise Access” and drill through the directories to select my primary MTA. After entering the directory as a drive letter or through unc path I receive an error in a “Systems Manager” dialogue box, “An unhandled exception has occurred in your application… ..eDirectory Tree could not be set.” I do have a multiple tree environment but login only to the primary MTA’s tree as an admin equivalent.

    Any questions, thoughts or suggestions?

    Thanks.

  • Author
    Replies
  • #9248
    Support 2
    Moderator

    If we assume that there is no problem with Archive To Go ‘seeing’ your Primary Domain path and primary domain database (wpdomain.db), it leaves us at the problem of authentication or access rights. Nothing in the GroupWise APIs enable us to preset any security or authentication settings and, without debug DLLs when possible, there is very little information returned upon authentication failure.

    Apart from obvious causes which result in authentication problems, such as correct user access rights, the only other problem of which we are aware involves a multiple eDirectory Tree topology. Generally customers experiencing an authentication problem have only a couple of Trees and logging into the ones which provide the appropriate level of access for the GroupWise APIs solved the problem.

    The APIs used are client based. Which version of the GroupWise Client are you using?

    Have you tried running Archive To Go in Enterprise Mode from another workstation?

    Have you tried reinstalling the GroupWise Client?

    If the authentication failure is occurring during the Trusted Application process, sometimes it is possible to get additional information about the problem by installing the GroupWise debug version of the Trusted API DLL. However, from your description, the process appears to be failing before this step, in fact during the very first step when the solution is attempting to connect to the primary domain.

    What may help is if you could ZIP and send to support@advansyscorp.com all files from the following folder:

    C:Documents and SettingsApplication DataAdvansysArchive To Go

    If you are not successful in finding the cause of the authentication problem and we can’t glean anything from the files above, it may be worth trying the Trusted API debug DLL, although as mentioned above it may not assist, in which case we’d need to consider another troubleshooting approach.

    Regards,

    Advansys Support

    #9249
    tbengert
    Participant

    I tried a different workstation (mine XP with SP2, the other 2000 with sp4) I logged in as me both times (admin equivalent and a mapped drive to theprimary MTA) and receive the same error.

    I have 15 trees and a variance of NetWare and Windows eDirectory trees out there and know I will not be able to login to all the trees and be able to map drives effectively to see if authentication is the issue.

    I removed and re-installed the GroupWise 6.5.4 client.

    I zipped the “Archive To Go” directory and mailed to support.

    Thanks,

    Todd

    #9250
    Support 2
    Moderator

    Thanks Todd, we have received your files. It is likely we will need to write a test application to try and identify specifics of your environment.

    Regards,

    Advansys Support

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.