/ Forums / Advansys Formativ / Formativ Creator / Access Violations

  • Creator
    Topic
  • #3577
    Anonymous

    Formativ 2.0.0.17 on a win2k sp4 machine keeps producing access violations. This occurs in design-time after setting the properties of controls i.e. ListView Columns or ToolButtons.

    I tried it on different machines with the same result. Is it my machine(s) or is this a known issue?

  • Author
    Replies
  • #5507
    Support 1
    Participant

    Thank you for your enquiry.

    This is indeed a known issue, which is addressed by the following (quoted from the Formativ Readme document):

    quote:


    – Not closing certain item editors in the Form Designer prior to saving the form may cause an access violation. You should manually close any popup form editors prior to saving a form.


    At this stage this is the only workaround that I know of. So for example, after using the ListView columns editor, you must close the editor before you close the Forms Designer (whether you save or cancel changes).

    I hope this information is helpful.

    Regards,
    Advansys Support

    #5514
    Anonymous

    Thanks for your reply.

    I also got access violations when setting the caption of a button or editing properties of controls other than the list view while working directly in the object inspector.

    Then suddenly these messages started to pop up in GroupWise when performing common tasks like opening a mail or pressing the ‘new mail’ button!

    So I had to re-setup GroupWise (6.5.4) and Formativ this morning and I don’t know yet if this installation will be stable.

    All in all it looks like programming in Formativ 2.0 made my GroupWise system crash (!) which is not very encouraging to me…

    slicky

    #5508
    Anonymous

    Here we go again:
    I was able to work for about 2 hours without crashing. Then I got another access violation when adding a dblclck event handler for a button. After this, Formativ responds to nearly every attempt of saving the changes I made in the Visual Forms Designer with an Access Violation or the very helpful message “Priviledged Instruction”.

    A restart of my PC did not resolve the issue.

    Version 1.6 wasn’t very stable but this is a joke.

    #5509
    Support 1a
    Participant

    We are sorry to hear of your frustrating experience. Other than the known issue of not closing certain editors mentioned above, we are not aware of any issues that might cause the problems you describe. We have not received any other reports of this problem. We have spent many 1000’s of man hours working in the Formativ 2.0 development environment and have not experienced anything like you describe. This leads me to believe the problem may be specific to your environment.

    Formativ makes use of several external components and services that may be responsible for unusual behavior if faulty. To this end, I would suggest you try the following steps to see if the problem can be eliminated:

    a) Formativ Installation

    On rare occasions we have seen installations that have become corrupt, presumably during the download process. I would suggest you download Formativ from our downloads page again, uninstall your existing version, and then re-install.

    b) GroupWise Client Installation

    On more than one occasion we have seen strange problems caused by invalid/incomplete GroupWise client installations. Some people install the GroupWise client using ZEN snapshots or other automated means. These images are sometimes incomplete or invalid. The client may appear to install and run fine, but a missing or old version of component, or an incorrect registry entry can cause all sorts of subtle, hard to track down problems. I would suggest to uninstall the GroupWise client (possibly using one of the client cleanup utilities that are about to ensure the client is completely gone), then re-install from a clean CD.

    c) Windows Service Pack Installation

    I would suggest you manually run Windows update to ensure you have the latest service packs installed.

    d) Microsoft Script Host Installation

    Formativ uses the MS script host. The script host libraries are used directly by the form designer environment. I would suggest you re-install the script host. You can download it from:

    http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=en

    e) Microsoft Script Debugger

    Do you have a copy of the MS script debugger installed? If so, try uninstalling it.

    f) Microsoft Internet Explorer Installation

    Formativ and GroupWise shared several dependencies on Internet Explorer. Please ensure you are running the latest version. Installing the latest version of IE helps ensure you have the most current versions of several critical Windows System files.

    g) Antivirus Software

    Try turning off any local anti-virus software. These can sometimes adversely affect the operation of other software, particularly some of the script host components.

    h) Video Drivers

    Formativ runs inside the GroupWise process. Being in the same process, both can affect the other. GroupWise does seem to be particularly sensitive to video driver issues. I would suggest you check you have the most current version of the video drivers for your card installed.

    I hope one or more of these suggestions help. While testing/troubleshooting, remember that Formativ and GroupWise run in the same process. If an obscure problem occurs, the chances are it will continue for the remainder of the GroupWise session. To this end, it is important to re-start the GroupWise client each time you change something during this process, or else the problem will likely to persist, even though the cause may have been removed.

    Please let us know how you proceed.

    Advansys Support

    #5513
    slicky
    Participant

    status report:

    -) deinstalled groupwise/formativ (sample applets, too)
    -) installed latest version of video driver
    -) installed ms scripting host
    -) got the latest updates for IE and w2k
    -) installed GW 6.5.4
    -) downloaded & installed formativ 2.0.0.17
    -) killed the symantec anti virus service…

    …and ran into the same frustrating problems again .

    I tried it on three different machines (w2k, xp) and
    it’s the same behaviour everywhere, which makes it hard
    to believe for me that I’m the only user with this problem.

    Can it be that the applet itself became somehow corrupt?

    #5512
    Support 1a
    Participant

    Thank you for the update. As mentioned above, we have not received any other reports of this issue.

    It is possible that the applet could be a factor. Would you be willing to email the applet to support@advansyscorp.com, along with a series of steps you take to cause the errors to occur? If you are able to consistently replicate the problem through a series of steps, please provide full details.

    Regards,

    Advansys Support

    #5511
    slicky
    Participant

    done. hope you can help.

    slicky

    #5510
    Support 1a
    Participant

    Thank you. We have received the applet. We will investigate and get back to you via direct email ASAP. We’ll also post our findings in this thread.

    Advansys Support

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.