/ Forums / Advansys Archive To Go, Advansys PST Creator / Archive To Go / Object reference not set to an instance of an object

  • Creator
    Topic
  • #5012
    timmk
    Participant

    I get that message often while archiving larger mailboxes. usually ones over 2gb. Although not every mailbox is affected.
    Also is it normal for the archive process to take up to 3 hours per 1gb of data?
    Below is a sample of a log with the error. I hope this keeps its formatting as I’m pasting it here. sorry if it doesn’t. Any insight to this would be greatly appreciated.

    2008-09-27 13:12:22.625-04:00 [E] Cannot access folder “RFP-Dupont”.
    Any messages in this folder will not be included in the archive:

    System.Runtime.InteropServices.COMException (0x80020009): An invalid argument was passed in the function call.
    at System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
    at Advansys.Formativ.Windows.ObjectAPI.DIGWFolders.Item(Object vr)
    at xe01358da1a7cb0fa.x8c887c0d883b5d9f.xa00f9cbf39adb381(Account x9f10b67444c4366c, XmlNode xe194d419c047adc5, String xd8e628e45cc6ecb2)
    2008-09-27 13:12:26.343-04:00 [E] Creator General Exception:

    System.NullReferenceException: Object reference not set to an instance of an object.
    at Advansys.Arctic.FolderInfo..ctor(String xeaf1b27180c0557b, String xc15bd84e01929885, String xe125219852864557, FolderTypeConstants x43163d22e8cd5a71, Folder x8b5b49efcd08ae0a)
    at xe01358da1a7cb0fa.x8c887c0d883b5d9f.xa00f9cbf39adb381(Account x9f10b67444c4366c, XmlNode xe194d419c047adc5, String xd8e628e45cc6ecb2)
    at xe01358da1a7cb0fa.x8c887c0d883b5d9f.xe54171db2ab552db(Account x9f10b67444c4366c, XmlNode xe194d419c047adc5, String xd8e628e45cc6ecb2)
    at xe01358da1a7cb0fa.x8c887c0d883b5d9f.x18dfca7c5fd2402f()

  • Author
    Replies
  • #9574
    Support 3
    Participant

    Which version of the Archive To Go you are running (Press the About button from the main dialog)? Please see below some suggestions from the engineers:

    • Have you tried doing a thorough GWCheck on these personal archives? We recommend running GWCheck on any account prior to archiving, but please be aware that we do receive a significant number of problem reports about personal archives. You may find that it helps to reboot the machine before running Archive To Go, especially if the machine has been running for two or more days.
    • Are there any folders in this account which contain 4,960 or more items? If so, could you try splitting them into smaller folders, Since Creator fails to access the first folder, you could start by splitting only one large folder to see whether that makes a difference. You could also try changing the order of one or two folders (to force a change to the personal archive database). Then try again to archive this account.

    Hope this helps. Please let us know how you go.

    Regards,
    Advansys Support

    #9573
    timmk
    Participant

    I am using 1.5.0.1

    I ran GWCheck on mailboxes. I am not trying to archive personal archives. the archives are being created in Enterprise mode.

    I have many mailboxes (8) which I am not able to archive due to these errors. and the creator will not even index the messages that it has archived prior to failing because of this message. I do not believe any folder has over 4,960 items.

    Is there a fix for this? I am having a very hard time with this software as it will take over 9 hours to get to the point where it fails and all I am left with are some files which I cant open because they weren’t indexed.

    #9575
    Support 1
    Participant

    Thanks for the additional information.

    If the errors listed in your logs are all similar to:

    quote:


    Cannot access folder “RFP-Dupont”


    then there may be some corruption in the mailbox database.

    I suggest you download and install the latest release (1.5.0.3) which includes some memory management optimizations that may prevent these errors. But before attempting to re-archive any of the problem mailboxes, please try the test described below.

    If the GWCheck report says nothing is wrong with any of the problem folders, then I suggest you try the following using 1.5.0.3.

    • Set a filter that will exclude all messages, in order to test folder archiving in the minimum possible time. A filter for this might be the date range: tomorrow or later.
    • If the previous step does not reproduce the errors, try re-archiving without setting a filter.
    • If the folder archiving test reproduces the errors, try moving the items from each affected folder to a new folder, eg. from “RFP-Dupont” -> “RFP-Dupont1”. Then delete the old folder and rename the new one as the original name. Then try re-archiving.

    If you continue to get these errors, please send the process log (zipped if larger than 200 KB) to support@advansyscorp.com.

    Finally, we do not have statistics available for how long it takes Archive To Go to archive 1 GB (for example). It would not be trivial to calculate such a statistic because so many variables are present in a GroupWise environment, eg. network latency, disk fragmentation, total mailbox database size. However it is likely that 1.5.0.3 reduces the time significantly due to the optimization mentioned above.

    I hope this helps.

    Regards,
    Advansys Support

    [This message was edited by Support 1 on October 06, 2008 at 06:00 PM.]

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.