/ Forums / Advansys Formativ / Creating Solutions with Formativ / HTML Signatures deletes content

  • Creator
    Topic
  • #3915
    Anonymous

    Hi,

    we’re just trying formativ – just impressive what’s possibe with that ‘thing’.

    Now our problem, we hope y can help:
    When writing a HTML-mail in GroupWise 6.5(!), following problem comes up:
    All the written content will be removed an content of the signatur-file lays over.
    If y use this applet when replying to an email, all the content of the mail will be deleted.

    There is no diference, if y use the *.hts-files shipped within formativ or if y take one, which is created by us.

    Everything works fine in our testing-developing system using GroupWise6 (on Win200), the problems comes up with GroupWise 6.5 on WinXP.

    The easiest way to demonstarte:
    Open a new mail, insert 3 lines by typing <ENTER> and then insert a signature. If y view the source of the mail, y’ll see the difference:

    (All ‘>’/'<‘ are replaced, so that HTML-Code won’t be interpreted!):

    GroupWise 6:
    [!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 4.0 Transitional//EN”]
    [HTML][HEAD]
    [META content=”text/html; charset=iso-8859-1″ http-equiv=Content-Type]
    [META content=”MSHTML 5.00.2920.0″ name=GENERATOR][/HEAD]
    [BODY style=”FONT: 8pt Tahoma; MARGIN-LEFT: 2px; MARGIN-TOP: 2px”´]
    [DIV] [/DIV]
    [DIV] [/DIV]
    [DIV] [/DIV]
    [DIV][IMG border=0 height=48
    src=”file:///C:/Programme/Advansys/Formativ/Data/Signatures/GroupWise65.gif”
    width=360] [/DIV][/BODY][/HTML]

    GroupWise 6.5 – all ‘<DIV>’s are missing!:
    [!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 4.0 Transitional//EN”´]
    [HTML][HEAD]
    [META http-equiv=Content-Type content=”text/html; charset=unicode”]
    [META content=”MSHTML 6.00.2600.0″ name=GENERATOR][/HEAD]
    [BODY style=”MARGIN: 4px 4px 1px; FONT: 10pt Tahoma”][IMG height=48
    src=”file:///C:/Program Files/Advansys/Formativ/Data/Signatures/GroupWise65.gif”
    width=360 border=0][/BODY][/HTML]

    Any hint, how to resolve the problem?

    Thanks in advance,
    Markus

  • Author
    Replies
  • #6603
    Support 2
    Moderator

    Thank you for your product feedback and for the problem notification. We discovered this problem late last week and our investigations with Novell have determined it is an issue in the GroupWise 6.5 client. While a resolution to the underlying client problem is likely to be available in GroupWise 6.5 SP1, in the interim we have researched a work-around. A test version of the updated Multiple Signatures solution was completed last Friday (Mar 14) and you can download it from the following URL:

    http://www.advansyscorp.com/beta/multiple%20signatures_15_bsp_flexalock.vbf

    The best way to download the updated applet is to highlight the link and do a ‘save as’ into the default applet folder, c:program filesadvansysformativlocal and then restart the GroupWise client. Please note that this is a beta test version and it has not yet undergone rigorous testing in-house. However, testing so far has not revealed any problems.

    The same ‘replacement’ issue affects the Stationery solution and an update is being tested in-house at present. This only affects users when a message being created already has text in the body, such as when replying, and then loading stationery. The problem won’t occur if you are creating a new message and load the stationery first.

    Another issue within the GroupWise 6.5 client means that the current ‘Personalized Mass Email’ solution no longer works effectively for HTML messages which are received within the same GW system (the HTML version can’t be seen on internal mail). It does work correctly for HTML personalized mass email messages which are sent via the GWIA, i.e. external messages. While this GW 6.5 client issue will be rectified in SP1, we are also finalizing an interim update for this solution.

    Fortunately it appears we will be able to address these 6.5 issues and we will make the updates available in the near future.

    Please let us know if you have any problems with the updated Multiple Signatures solution.

    Kind regards,

    Advansys Support

    #6605
    Anonymous

    Thanks very much for your quick reply!
    So our assumption was right, that this is a problem of the GW 6.5 client.
    Very kind to get the possibility of an updated version of the ‘multiple signatures’-Applet, but it’s a ‘flexalock’-Version, so we can’t figure out which changes have to be made, when we want to write an own version of such an applet.
    The important line should be
    # GroupWise.Retrieve(SigFile)
    Which sort of changes should be made?

    Greeetings from Austria,
    Markus

    #6604
    Support 1a
    Participant

    Markus has been contacted directly regarding this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.